Tuesday, April 9, 2013

SharePoint 2013: Dashboard Designer Not Showing Databases from Analysis Services - Resolution

Currently only 1 WFE
PPS Service running on 1 Application Server
Unattended Service Account entered via the PPS Service Application
Same service account belongs to a Role in SSAS (2012) with Read permissions on a cube
BI Center Site Collection created

Launch Dashboard Designer
Create New Data Source from Analysis Services
Enter Analysis Services Server
Database drop-down shows Loading... but then nothing appears in drop-down list.


  1. Install  Microsoft® SQL Server® 2012 ADOMD.NET and Microsoft® Analysis Services OLE DB Provider for Microsoft® SQL Server® 2012 from the Microsoft® SQL Server® 2012 Feature Pack on the WFE and the server running the PPS Service
  2. Install  Microsoft® SQL Server® 2008 R2 ADOMD.NET and Microsoft® Analysis Services OLE DB Provider for Microsoft® SQL Server® 2008 R2 from the Microsoft® SQL Server® 2008 R2 Feature Pack on the WFE and the server running the PPS Service
  3. IISRESET on the WFE and the server running PPS.
  4. Refresh the BI Center Site Collection
  5. Launch Dashboard Designer again from BI Center Site Collection
  6. Enter SSAS Server Name
  7. Database drop-down loads with the databases now!

I wouldn't be suprised if I need to install ADOMD.NET on any new WFEs that I build out but I will update this post when that time comes.

UPDATE 5/28/2013: I built out a new WFE and suprisingly I did not have to install ADOMD.NET. Everything appears to be working correctly.



  1. Ran into the same problem and this fixed my issue. Thanks!

  2. Thank you!!! Strange that you need the SQL2008R2 bits too...

  3. Great post, really useful. How come ADOMD.NET 2008 R2 is needed? Do you have any idea?

    Thanks again :)


    1. I believe I needed it in our environment since we had cubes running under SQL Server 2008 R2. You may not need it if you are solely on SQL Server 2012 but I don't have a way of testing that theory.

    2. Hi Steve,

      first of all, thanks for the good post.
      I tested in SQL Server 2012 and I didnt install ADOMD.NET 2008 R2.
      and it still shows 'Loading...'
      *I just wanted to confirm this issue.

      and because it just show 'Loading...' -> then I install the ADOMD.NET 2008 R2 as you mentioned above.
      and it works :)

      thank you.

  4. Hi Steve,

    Thanks!!!! you save my day...

    Cheers, Luis

  5. Thanks!! You saved my day!

  6. Thanx it resolves my issue with accuracy ...

  7. I have the same issue... I installed as you said but not work :( Is possible to use some command in Power Shell to check my Sharepoint settings? Do you know?

    1. I don't know what setting you can check. Did you install both 2008 and 2012 drivers?

  8. i installed both versions of adomd.net.it is populating me database but not showing me cubes .please help me out.i spent almost 1 day but couldnot fix it

    1. Make sure the SharePoint service account has read permissions on the cubes.

    2. iam very new to sharepoint.can u explain me in detail about how to do that

    3. You need to go into SQL Server Analysis Services or SQL Management Studio and modify the security of the cubes. Whatever service account is running the SharePoint app pools needs to have read access.Here is a good tutorial: http://msdn.microsoft.com/en-us/library/cc304417.aspx

    4. The service account should be the one that was entered as the Unatrended Service Account. Ours is the same as the app pool account.

    5. thank you.i already tried that way.my unattended account is domain/administrator and i created a role with domain name in analysis service.but still iam not finding cube in dashboard desginer :(

  9. Thank you very much, we are building a new SharePoint 2013 server and had this exact problem. Your solution worked beautifully.

  10. Thanks so much. I saved my day.

  11. Ɯberthanks!!!


Matched Content