Wednesday, January 16, 2013

SharePoint 2013: Activating Video Support in Your Site Collection

A few weeks ago, I wrote a post on using videos in SharePoint 2013 . However, as a reader pointed out, I did not really explain how to make sure that your site collection was set up to support videos and media. So here it is.

To enable video support within SharePoint 2013, you need to activate the Video and Media feature at the site collection level. Here are the quick and easy steps to perform this activation.

Step 1: From the Settings (gear icon) menu on your site collection, select Site Settings.


 
Step 2: Click on Site Collection Features under the Site Collection Administration section.
 
Step 3: Scroll down and find the Video and Media feature. Click on Activate to activate the feature.
 
Step 4: Return to your site collection. When you go to add an app for Videos, use the Asset Library:
 

 
 
Learn how to embed YouTube videos into your library.
Learn how to link to videos outside of SharePoint.

 

4 comments:

  1. Hi, thanks for the post. Is any of this available in Foundation 2013?

    ReplyDelete
    Replies
    1. It appears that it is not available in SharePoint Foundation 2013.

      Delete
  2. I cannot seem to get any videos from outside server to play. I only get file://name.mpg instead of http://name.mpg. Has there been any improvement on the Web Media Web Part?

    ReplyDelete
    Replies
    1. You need to edit the HTML Security on the site and add the external domain

      Delete